Probleme bei UPS Etiketten Erzeugung
Incident Report for microtech GmbH
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 12:17 CET
Investigating
We are currently investigating this issue.
Posted Mar 05, 2024 - 11:54 CET
This incident affected: Shipping Services (UPS).